為編程愛好者分享易語言教程源碼的資源網
挂機,挂機器人服務器88一年 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 每日必買商品
注冊機|遊戲腳本|透視輔助|視頻教程 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 挂機,挂機器人服務器88一年
易語言|按鍵精靈|app逆向|微信hook 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 A全站文字廣告,誠邀與您合作

網站首頁 易語言相關 網絡相關源碼 正文

Telnet服務端易語言源碼

三葉資源網 2013-03-02 網絡相關源碼 908 ℃ 3 評論

源碼調用了易語言擴展界面支持庫,使用易語言服務器組件實現了Telnet服務端應用。

@愛三葉資源網源碼

.版本 2
.支持庫 iext

.程序集 窗口程序集1
.程序集變量 telnet客戶, telnet客戶, , "0"

.子程序 _服務器1_客戶進入
.局部變量 臨時_telnet客戶, telnet客戶

臨時_telnet客戶.地址 = 服務器1.取回客戶 ()
加入成員 (telnet客戶, 臨時_telnet客戶)
服務器1.發送數據 (服務器1.取回客戶 (), 到字節集 (編輯框1.内容 + #換行符), )
服務器1.發送數據 (服務器1.取回客戶 (), 到字節集 (“用戶名:”), )

.子程序 _服務器1_數據到達
.局部變量 用戶組ID, 整數型
.局部變量 來數據客戶, 文本型
.局部變量 數據, 字節集
.局部變量 i, 整數型
.局部變量 temp, 整數型
.局部變量 temp2, 整數型
.局部變量 命令, 文本型

來數據客戶 = 服務器1.取回客戶 ()
數據 = 服務器1.取回數據 ()
.計次循環首 (取數組成員數 (telnet客戶), i)
    .如果真 (telnet客戶 [i].地址 = 來數據客戶)
        用戶組ID = i
        跳出循環 ()
    .如果真結束
    ' 三葉資源網(juhua445643.cn)
.計次循環尾 ()
.如果真 (數據 = { 8 })
    返回 ()
.如果真結束
.如果真 (數據 = { 13, 10 })
    .如果真 (telnet客戶 [用戶組ID].是否驗證通過 = 假)
        .判斷開始 (telnet客戶 [用戶組ID].是否輸入用戶名 = 假)
            列表框1.加入項目 (“得到用戶名:” + telnet客戶 [用戶組ID].命令, )
            temp = 驗證用戶名 (telnet客戶 [用戶組ID].命令)
            .如果真 (temp = -1)
                服務器1.發送數據 (服務器1.取回客戶 (), 到字節集 (“輸入用戶名錯誤請重新輸入” + #換行符 + “用戶名:”), )
                telnet客戶 [用戶組ID].命令 = “”
                返回 ()
            .如果真結束
            telnet客戶 [用戶組ID].用戶名 = temp
            telnet客戶 [用戶組ID].是否輸入用戶名 = 真
            telnet客戶 [用戶組ID].命令 = “”
            服務器1.發送數據 (服務器1.取回客戶 (), 到字節集 (“密碼:”), )
        .判斷 (telnet客戶 [用戶組ID].是否輸入密碼 = 假)
            列表框1.加入項目 (“得到密碼:” + telnet客戶 [用戶組ID].命令, )
            .如果 (驗證密碼 (telnet客戶 [用戶組ID].用戶名, telnet客戶 [用戶組ID].命令) = 真)
                telnet客戶 [用戶組ID].是否驗證通過 = 真
                telnet客戶 [用戶組ID].是否輸入密碼 = 真
                服務器1.發送數據 (服務器1.取回客戶 (), 到字節集 (“成功登入您的權限是:” + 超級列表框1.取标題 (telnet客戶 [用戶組ID].用戶名, 2) + #換行符), )
                ' 上面這條可以發送以下登入成功後的信息!
                telnet客戶 [用戶組ID].名稱 = 超級列表框1.取标題 (telnet客戶 [用戶組ID].用戶名, 1)
                返回命令 (服務器1.取回客戶 (), telnet客戶 [用戶組ID].名稱)
                temp2 = 超級列表框2.插入表項 (, 到文本 (超級列表框2.取表項數 ()), , , , )
                超級列表框2.置标題 (temp2, 1, 服務器1.取回客戶 ())
                超級列表框2.置标題 (temp2, 2, 超級列表框1.取标題 (telnet客戶 [用戶組ID].用戶名, 0))
                超級列表框2.置标題 (temp2, 3, 超級列表框1.取标題 (telnet客戶 [用戶組ID].用戶名, 1))
                超級列表框2.置标題 (temp2, 4, 超級列表框1.取标題 (telnet客戶 [用戶組ID].用戶名, 2))
                ' 三葉資源網(juhua445643.cn)
                telnet客戶 [用戶組ID].命令 = “”
            .否則
                telnet客戶 [用戶組ID].是否輸入用戶名 = 假
                telnet客戶 [用戶組ID].命令 = “”
                服務器1.發送數據 (服務器1.取回客戶 (), 到字節集 (“輸入信息錯誤請重新輸入” + #換行符 + “用戶名:”), )
            .如果結束

        .默認

        .判斷結束
        返回 ()
    .如果真結束
    命令 = telnet客戶 [用戶組ID].命令
    列表框1.加入項目 (“得到命令:” + 命令, )
    telnet客戶 [用戶組ID].命令 = “”
    .如果真 (命令 = “hlep”)  ' 再這個後面接着各種分析自己的命令和參數就可以了!~~~~~~
        服務器1.發送數據 (服務器1.取回客戶 (), 到字節集 (“         shutdown     關機命令 跟參數 秒” + #換行符), )
    .如果真結束
    返回命令 (服務器1.取回客戶 (), telnet客戶 [用戶組ID].名稱)
    返回 ()
.如果真結束
telnet客戶 [用戶組ID].命令 = telnet客戶 [用戶組ID].命令 + 到文本 (數據)

.子程序 __啟動窗口_創建完畢
.局部變量 temp, 整數型

temp = 超級列表框1.插入表項 (, “user”, , , , )
超級列表框1.置标題 (temp, 1, “user”)
超級列表框1.置标題 (temp, 2, “1”)
temp = 超級列表框1.插入表項 (, “admin”, , , , )
超級列表框1.置标題 (temp, 1, “admin”)
超級列表框1.置标題 (temp, 2, “2”)
temp = 超級列表框1.插入表項 (, “super”, , , , )
超級列表框1.置标題 (temp, 1, “super”)
超級列表框1.置标題 (temp, 2, “3”)
' 三葉資源網(juhua445643.cn)

.子程序 驗證用戶名, 整數型
.參數 用戶名, 文本型
.局部變量 i, 整數型

.計次循環首 (超級列表框1.取表項數 (), i)
    .如果真 (超級列表框1.取标題 (i - 1, 0) = 用戶名)
        跳出循環 ()
    .如果真結束

.計次循環尾 ()
.如果真 (超級列表框1.取标題 (i - 1, 0) = 用戶名)
    返回 (i - 1)
.如果真結束
返回 (-1)

.子程序 驗證密碼, 邏輯型
.參數 用戶名ID, 整數型
.參數 密碼, 文本型

.如果真 (超級列表框1.取标題 (用戶名ID, 1) = 密碼)
    返回 (真)
.如果真結束
返回 (假)

.子程序 驗證用戶, 邏輯型
.參數 用戶名, 文本型
.參數 密碼, 文本型

' 三葉資源網(juhua445643.cn)

.子程序 返回命令
.參數 用戶, 文本型
.參數 名稱, 文本型

服務器1.發送數據 (用戶, 到字節集 (名稱 + “@:”), )


.子程序 __啟動窗口_将被銷毀



.子程序 _服務器1_客戶離開
.局部變量 i, 整數型

.計次循環首 (取數組成員數 (telnet客戶), i)
    .如果真 (telnet客戶 [i].地址 = 服務器1.取回客戶 ())
        删除成員 (telnet客戶, i, )
        跳出循環 ()
    .如果真結束
    ' 三葉資源網(juhua445643.cn)
.計次循環尾 ()
.計次循環首 (超級列表框2.取表項數 (), i)
    .如果真 (超級列表框2.取标題 (i - 1, 1) = 服務器1.取回客戶 ())
        超級列表框2.删除表項 (i - 1)
        跳出循環 ()
    .如果真結束

.計次循環尾 ()

   

文件下載


Tags:

來源:三葉資源網,歡迎分享,公衆号:iisanye,(三葉資源網④群:72857039

已有3位網友發表了看法:

歡迎 發表評論:

百度站内搜索
關注微信公衆号
三葉資源網④群:三葉資源網③群

網站分類
随機tag
QQ空間分享删除計算剩餘時間多線程撥号代碼網易滑塊位置識别多線程注冊易語言資源網世寶教程cnzzt統計正則表達式測試工具動态特效跳一跳彗星HTTP支持庫文件分割器動态創建窗口E2EE支持庫中間件是否被修改封包組包易語言支持庫EXDUI4.1例程
最新評論