為編程愛好者分享易語言教程源碼的資源網
挂機,挂機器人服務器88一年 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 每日必買商品
注冊機|遊戲腳本|透視輔助|視頻教程 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 挂機,挂機器人服務器88一年
易語言|按鍵精靈|app逆向|微信hook 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 A全站文字廣告,誠邀與您合作

網站首頁 易語言相關 網絡相關源碼 正文

易語言取多網卡MAC地址源碼

三葉資源網 2013-03-02 網絡相關源碼 374 ℃ 1 評論

源碼通過API函數取多網卡MAC地址。源碼是WINDOWS API學習例程。

@黑客源碼

.版本 2

.子程序 網絡_取本機MAC, 文本型, 公開, 獲取本機MAC地址,可以獲取多網卡MAC,失敗返回空。
.參數 網卡序号, , 可空, 可以被省略。當本機有多塊網卡時,指定要對其操作的網卡序号(從1開始)。
.局部變量 IPAA, IP_ADAPTER_ADDRESSES
.局部變量 pAdapterAddresses
.局部變量 outBufLen
.局部變量 Flags
.局部變量 Family
.局部變量 lRet
.局部變量 dwIndex
.局部變量 i
.局部變量 outBuff, 文本型, , "0"
.局部變量 MAC地址, 文本型, , "0"
.局部變量 tmpMAC, 文本型

Flags = 16
Family = 0
outBufLen = 0
pAdapterAddresses = 從堆棧分配内存_ (取進程堆棧句柄_ (), 8, 32)
lRet = GetAdaptersAddresses (Family, Flags, 0, pAdapterAddresses, outBufLen)  ' 第一次調用,如果緩沖區不夠,會在outBufLen裡返回所需要的緩沖區大小
.如果真 (lRet = 111)  ' 如果返回溢出,則重分配足夠的内存
    pAdapterAddresses = HeapReAlloc (取進程堆棧句柄_ (), 8, pAdapterAddresses, outBufLen)
.如果真結束
lRet = GetAdaptersAddresses (Family, Flags, 0, pAdapterAddresses, outBufLen)  ' 這次是正式取了
.如果真 (lRet = 0)
    ' 三葉資源網(juhua445643.cn)
    i = 0
    重定義數組 (outBuff, 假, 1)
    拷貝内存_IP_ADAPTER (IPAA, pAdapterAddresses, Len_IP_ADAPTER (IPAA))
    tmpMAC = 取十六進制文本 (IPAA.PhysicalAddress [1]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [2]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [3]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [4]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [5]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [6])
    加入成員 (MAC地址, tmpMAC)
    .判斷循環首 (IPAA.pNext ≠ 0)
        i = i + 1
        重定義數組 (outBuff, 真, i)
        拷貝内存_IP_ADAPTER (IPAA, IPAA.pNext, Len_IP_ADAPTER (IPAA))
        tmpMAC = 取十六進制文本 (IPAA.PhysicalAddress [1]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [2]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [3]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [4]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [5]) + “-” + 取十六進制文本 (IPAA.PhysicalAddress [6])
        .如果真 (tmpMAC ≠ “0-0-0-0-0-0”)
            ' 三葉資源網(juhua445643.cn)
            加入成員 (MAC地址, tmpMAC)
        .如果真結束
        處理事件 ()
    .判斷循環尾 ()
.如果真結束
釋放堆棧内存_ (取進程堆棧句柄_ (), 0, pAdapterAddresses)
.如果真 (是否為空 (網卡序号))
    網卡序号 = 1
.如果真結束
返回 (MAC地址 [網卡序号])
文件下載


Tags:

來源:三葉資源網,歡迎分享,公衆号:iisanye,(三葉資源網④群:72857039

已有1位網友發表了看法:

歡迎 發表評論:

百度站内搜索
關注微信公衆号
三葉資源網④群:三葉資源網③群

網站分類
随機tag
采集網頁圖片源碼仿QQ音樂播放器鼠标離開懸停ERP管理系統朗讀窗口特效Charles吃雞泰服矩陣md5效驗自動打怪kktv小号桃源挖礦B站cookie易語言通訊QQ主顯準星拖動HttpWatch郵箱轟炸器HttpWatch破解版
最新評論