為編程愛好者分享易語言教程源碼的資源網
挂機,挂機器人服務器88一年 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 每日必買商品
注冊機|遊戲腳本|透視輔助|視頻教程 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 挂機,挂機器人服務器88一年
易語言|按鍵精靈|app逆向|微信hook 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 A全站文字廣告,誠邀與您合作

網站首頁 易語言相關 網絡相關源碼 正文

易語言TCP讀HTTP文件源碼

三葉資源網 2013-03-10 網絡相關源碼 319 ℃ 1 評論

源碼調用了易語言客戶組件,演示了TCP方式訪問網絡的過程。

@客戶端

.版本 2

.程序集 窗口程序集1
.程序集變量 計時

.子程序 _按鈕1_被單擊

.如果真 (客戶1.連接 (“www.pctowap.com”, 80))
    .如果真 (客戶1.發送數據 (#常量1))
        計時 = 取啟動時間 ()
        返回 ()
    .如果真結束

.如果真結束
信息框 (“網絡連接失敗”, 0, “”)

.子程序 _客戶1_數據到達
.局部變量 數據, 文本型

數據 = 到文本 (客戶1.取回數據 ())
編輯框1.加入文本 (數據)
.如果真 (尋找文本 (數據, “0” + #換行符 + #換行符, , 假) ≠ -1)
    客戶1.斷開連接 ()
    标題 = “ok  耗時-” + 到文本 (取啟動時間 () - 計時) + “毫秒”
.如果真結束
文件下載


Tags:

來源:三葉資源網,歡迎分享,公衆号:iisanye,(三葉資源網④群:72857039

已有1位網友發表了看法:

歡迎 發表評論:

百度站内搜索
關注微信公衆号
三葉資源網④群:三葉資源網③群

網站分類
随機tag
AI文字轉語音QQ空間分享删除變現易語言教程解析單課基礎課程集合HOOK攔截社會網絡系統DPI縮放率前端抖音快手注冊源碼易語言多線程強行兼容高DPI支持庫教程益友會動态加解密SysDateTimePick32彙編RdRand酷狗繁星PC協議
最新評論