為編程愛好者分享易語言教程源碼的資源網
挂機,挂機器人服務器88一年 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 每日必買商品
注冊機|遊戲腳本|透視輔助|視頻教程 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 挂機,挂機器人服務器88一年
易語言|按鍵精靈|app逆向|微信hook 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 A全站文字廣告,誠邀與您合作

網站首頁 易語言相關 網絡相關源碼 正文

易語言FTP超時處理源碼

三葉資源網 2013-03-11 網絡相關源碼 246 ℃ 0 評論

資源介紹:

易語言FTP超時處理源碼,通過調用windowsAPI實現了FTP超時處理。

資源作者:

@易語言自學網

資源界面:

.版本 2
.支持庫 EThread
.支持庫 spec

.程序集 程序集1

.子程序 _啟動子程序, 整數型, , 本子程序在程序啟動後最先執行

置随機數種子 ()
标準輸出 (, “START...”)
啟動線程 (&demo, , )
标準輸入 ()
API_FreeConsole ()  ' 64位沒辦法
返回 (0)  ' 可以根據您的需要返回任意數值

.子程序 demo
.局部變量 szHost, 文本型
.局部變量 szUser, 文本型
.局部變量 szPass, 文本型
.局部變量 szLocalFile, 文本型
.局部變量 szRemoteFile, 文本型
.局部變量 dwExitCode, 整數型
.局部變量 dwTimeout, 整數型
.局部變量 threadParam, PARM
.局部變量 hThread, 整數型
.局部變量 dwThreadId, 整數型
.局部變量 buff, 文本型

g_hOpen = 0
szHost = 到文本 (取随機數 (1, 255)) + “.” + 到文本 (取随機數 (1, 255)) + “.” + 到文本 (取随機數 (1, 255)) + “.” + 到文本 (取随機數 (1, 255))
調試輸出 (szHost)
szUser = “Jiesoft”
szPass = “2012”
g_hOpen = API_InternetOpen (“FTP sample”, #INTERNET_OPEN_TYPE_DIRECT, 0, 0, 0)
.如果真 (g_hOpen = 0)
    标準輸出 (, #換行符 + “Error on InternetOpen: ” + 到文本 (API_GetLastError ()))
    标準輸出 (, #換行符 + “END...”)
    返回 ()
.如果真結束
threadParam.pHost = szHost
threadParam.pUser = szUser
threadParam.pPass = szPass
hThread = API_CreateThread (0, 0, 到整數 (&WorkerFunction), 取變量數據地址 (threadParam), 0, dwThreadId)
dwTimeout = 5000
.如果真 (API_WaitForSingleObject (hThread, dwTimeout) = #WAIT_TIMEOUT)
    标準輸出 (, #換行符 + “Can not connect to server in ” + 到文本 (dwTimeout) + “ milliseconds”)
    .如果真 (g_hOpen ≠ 0)
        API_InternetCloseHandle (g_hOpen)
    .如果真結束
    API_WaitForSingleObject (hThread, #INFINITE)
    标準輸出 (, #換行符 + “Thread has exited”)
    标準輸出 (, #換行符 + “END...”)
    返回 ()
.如果真結束
dwExitCode = 0
.如果真 (API_GetExitCodeThread (hThread, dwExitCode) = 0)
    标準輸出 (, #換行符 + “Error on GetExitCodeThread: ” + 到文本 (API_GetLastError ()))
    标準輸出 (, #換行符 + “END...”)
    返回 ()
.如果真結束
API_CloseHandle (hThread)
.如果真 (API_FtpGetFile (g_hConnect, szRemoteFile, szLocalFile, 0, #INTERNET_FLAG_RELOAD, #FTP_TRANSFER_TYPE_ASCII, 0) = 0)
    标準輸出 (, #換行符 + “Error on FtpGetFile: ” + 到文本 (API_GetLastError ()))
.如果真結束
.如果真 (g_hConnect ≠ 0)
    API_InternetCloseHandle (g_hConnect)
.如果真結束
.如果真 (g_hOpen ≠ 0)
    API_InternetCloseHandle (g_hOpen)
.如果真結束
标準輸出 (, #換行符 + “END...”)

.子程序 WorkerFunction, 整數型
.參數 vThreadParm, 整數型
.局部變量 pThreadParm, PARM
.局部變量 buff, 文本型

置入代碼 ({ 139, 93, 8, 139, 3, 137, 69, 252 })
g_hConnect = API_InternetConnect (g_hOpen, pThreadParm.pHost, #INTERNET_INVALID_PORT_NUMBER, pThreadParm.pUser, pThreadParm.pPass, #INTERNET_SERVICE_FTP, 0, 0)
.如果真 (g_hConnect = 0)
    标準輸出 (, #換行符 + “Error on InternetConnnect: ” + 到文本 (API_GetLastError ()))
    返回 (1)
.如果真結束
返回 (0)

資源下載:

文件下載

Tags:

來源:三葉資源網,歡迎分享,公衆号:iisanye,(三葉資源網④群:72857039

本文暫時沒有評論,來添加一個吧(●'◡'●)

歡迎 發表評論:

百度站内搜索
關注微信公衆号
三葉資源網④群:三葉資源網③群

網站分類
随機tag
原子鎖讀卡器開發禁止重複運行ckplayer示例百度雲計算圖片識别圖解深度學習超級列表框XUI界面Aplayer易語言源碼網TGP饑荒一鍵指令工具eWOW64Ext線程JS教程硬盤遍曆幻影動圖特效胡來網post注冊未聞花名皮膚模塊圖片生成器
最新評論