為編程愛好者分享易語言教程源碼的資源網
挂機,挂機器人服務器88一年 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 每日必買商品
注冊機|遊戲腳本|透視輔助|視頻教程 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 挂機,挂機器人服務器88一年
易語言|按鍵精靈|app逆向|微信hook 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 A全站文字廣告,誠邀與您合作

網站首頁 易語言相關 網絡相關源碼 正文

讀WAP網頁易語言源碼

三葉資源網 2012-05-27 網絡相關源碼 415 ℃ 0 評論

源碼通過創建XMLHTTP對象,實現了網頁訪問功能,并且源碼還實現了編碼轉化。

.版本 2

.子程序 讀wap, 字節集, 公開, 讀網絡文件,(成功返回網絡文件字節集數據,失敗返回空字節集)
.參數 完整網址, 文本型, , 欲訪問的完整的網絡地址
.參數 訪問方式, 文本型, 可空, "GET" or "POST",為空默認"GET"
.參數 提交數據, 文本型, 可空, 隻限POST
.局部變量 對象, 對象
.局部變量 bp, 變體型

.如果真 (對象.創建 (“Microsoft.XMLHTTP”, ))
    .如果真 (取反 (取文本左邊 (到大寫 (完整網址), 7) = “HTTP://”))
        完整網址 = “HTTP://” + 完整網址
    .如果真結束
    .如果真 (訪問方式 = “”)
        訪問方式 = “GET”
    .如果真結束
    對象.方法 (“open”, 訪問方式, 完整網址, 假)
    對象.方法 (“SetRequestHeader”, “Accept”, “application/vnd.wap.xhtml+xml,application/xml,text/vnd.wap.wml,text/html,application/xhtml+xml,image/png;q=0.5,image/jpeg;q=0.5,image/gif;q=0.5,image/*;q=0.6,*/*;q=0.6”)
    對象.方法 (“SetRequestHeader”, “User-Agent”, “SonyEricssonK800”)
    對象.方法 (“SetRequestHeader”, “Q-UA”, “KQB21_GA/210013&KMTT_3/200013&JV2&152020&SonyEricssonK800&0&4021&V3”)
    對象.方法 (“send”, 提交數據)
    bp = 對象.讀屬性 (“responseBody”, )
    返回 (bp.取字節集 ())
.如果真結束
返回 ({  })
文件下載

Tags:

來源:三葉資源網,歡迎分享,公衆号:iisanye,(三葉資源網④群:72857039

本文暫時沒有評論,來添加一個吧(●'◡'●)

歡迎 發表評論:

百度站内搜索
關注微信公衆号
三葉資源網④群:三葉資源網③群

網站分類
随機tag
Pc微信Hook源碼彗星解碼注冊美團套接字超文本浏覽框支持庫微博授權捆綁程序超級列表框卡盟管理系統取啟動時間畫CPU折線圖Vstart登錄上傳TCP服務器進程信息聚享遊post雲的多文檔窗口界面支持庫勒索病毒
最新評論