為編程愛好者分享易語言教程源碼的資源網
挂機,挂機器人服務器88一年 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 每日必買商品
注冊機|遊戲腳本|透視輔助|視頻教程 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 挂機,挂機器人服務器88一年
易語言|按鍵精靈|app逆向|微信hook 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 A全站文字廣告,誠邀與您合作

網站首頁 易語言相關 網絡相關源碼 正文

快速讀取網頁易語言源碼

三葉資源網 2012-05-27 網絡相關源碼 532 ℃ 4 評論

源碼程序創建Microsoft.XMLHTTP對象快速讀取網頁源碼。

@易語言學習網

.版本 2

.子程序 XMLhttp讀文件, 字節集, 公開, 讀網絡文件,(成功返回網絡文件字節集數據,失敗返回空字節集)
.參數 網址, 文本型, , 欲訪問的網絡地址
.局部變量 對象, 對象
.局部變量 bp, 變體型

.如果真 (對象.創建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小寫 (取文本左邊 (網址, 7)) ≠ “http://”)
        網址 = “http://” + 網址
    .如果真結束
    對象.方法 (“open”, “GET”, 網址, 假)

    對象.方法 (“send”, )
    bp = 對象.讀屬性 (“responseBody”, )
    返回 (bp.取字節集 ())
.如果真結束
返回 ({  })

.子程序 XMLhttp讀文本, 文本型, 公開, 讀網絡文本,(成功返回網絡文本數據,失敗返回空文本)
.參數 網址, 文本型, , 欲訪問的網絡地址
.局部變量 對象, 對象
.局部變量 bp, 變體型

.如果真 (對象.創建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小寫 (取文本左邊 (網址, 7)) ≠ “http://”)
        網址 = “http://” + 網址
    .如果真結束
    對象.方法 (“open”, “GET”, 網址, 假)
    對象.方法 (“send”, )
    bp = 對象.讀屬性 (“responseBody”, )
    返回 (到文本 (bp.取字節集 ()))
.如果真結束
返回 (“”)
文件下載


Tags:易語言源碼

來源:三葉資源網,歡迎分享,公衆号:iisanye,(三葉資源網④群:72857039

已有4位網友發表了看法:

歡迎 發表評論:

百度站内搜索
關注微信公衆号
三葉資源網④群:三葉資源網③群

網站分類
随機tag
網頁解析類移動咪咕創建進程校驗車輛識别号遞歸算法代理注冊動态加密算法辣媽幫窗口信息sqllite限制未授權U盤點菜系統多進程LOL取色器PNG素材APP加密獲取本機信息MIDI解析找色
最新評論