為編程愛好者分享易語言教程源碼的資源網
挂機,挂機器人服務器88一年 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 每日必買商品
注冊機|遊戲腳本|透視輔助|視頻教程 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 挂機,挂機器人服務器88一年
易語言|按鍵精靈|app逆向|微信hook 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 A全站文字廣告,誠邀與您合作

網站首頁 易語言相關 網絡相關源碼 正文

簡單天涯對象法登錄回貼采集全易語言源碼

三葉資源網 2012-05-27 網絡相關源碼 342 ℃ 0 評論

資源介紹:

簡單天涯登錄回貼采集易語言源碼例程程序結合易語言擴展界面支持庫,調用API函數實現天涯登錄回貼采集。易語言例程還使用到易語言互聯網支持庫,正則表達式支持庫,超文本浏覽框支持庫,應用接口支持庫。

資源作者:

@三葉資源網

.版本 2
.支持庫 spec

.子程序 三無産品點擊
.局部變量 句柄a, 整數型
.局部變量 對象集合, 對象
.局部變量 網頁元素, 對象
.局部變量 網頁元素1, 對象
.局部變量 計次1, 整數型
.局部變量 value, 文本型
.局部變量 type, 文本型
.局部變量 title, 文本型
.局部變量 fhf, 文本型, , "0"
.局部變量 add, 整數型, 靜态

fhf = 分割文本 (回複.内容, #換行符, )
句柄a = 取網頁句柄 (超文本浏覽框1.取窗口句柄 ())
對象集合 = 取網頁對象 (句柄a)
調試輸出 (句柄a)

網頁元素 = 對象集合.對象型方法 (“getElementById”, “textAreaContainer”)
.如果 (選擇框2.選中 = 真)
    add = add + 1
    網頁元素.寫屬性 (“value”, fhf [add], )
    調試輸出 (fhf [add])
    調試輸出 (add)
    .如果真 (add = 取數組下标 (fhf, ))
        add = 0
    .如果真結束

.否則
    網頁元素.寫屬性 (“value”, 回複.内容, )
    調試輸出 (回複.内容)
.如果結束

網頁元素 = 對象集合.對象型方法 (“getElementsByTagName”, “input”)
.計次循環首 (網頁元素.讀數值屬性 (“length”, ), 計次1)
    網頁元素1 = 網頁元素.對象型方法 (“item”, 計次1 - 1)  ' item的第一個參數是索引,從0開始。
    type = 網頁元素1.讀文本屬性 (“type”, )
    value = 網頁元素1.讀文本屬性 (“value”, )
    title = 網頁元素1.讀文本屬性 (“title”, )
    .如果真 (type = “button” 或 value = “回複(Ctrl+Enter)” 或 title = “Ctrl+Enter快捷發表”)
        網頁元素1.方法 (“click”, )
        到循環尾 ()
    .如果真結束

.計次循環尾 ()
.判斷開始 (選擇框2.選中 = 假)
    時鐘1.時鐘周期 = 0
.默認

.判斷結束
' 如果真 (Type = “button” 或 Type = “submit” 或 Type = “reset” 或 Type = “image”)

資源下載:

文件下載


Tags:

來源:三葉資源網,歡迎分享,公衆号:iisanye,(三葉資源網④群:72857039

本文暫時沒有評論,來添加一個吧(●'◡'●)

歡迎 發表評論:

百度站内搜索
關注微信公衆号
三葉資源網④群:三葉資源網③群

網站分類
随機tag
内存注入模塊支持庫開源apk查殼工具多功能記事本系統服務優化向導QQ取本機cookie倉庫管理消息監聽HttpWatch黑月支持庫插件服務器組件精易模塊源碼模塊反編譯CHM幫助文檔Windows身份驗證組件使用例程QQ授權登陸關鍵詞采集腳本源碼BPL綜合例程
最新評論