為編程愛好者分享易語言教程源碼的資源網
挂機,挂機器人服務器88一年 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 每日必買商品
注冊機|遊戲腳本|透視輔助|視頻教程 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 挂機,挂機器人服務器88一年
易語言|按鍵精靈|app逆向|微信hook 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 A全站文字廣告,誠邀與您合作

網站首頁 易語言相關 網絡相關源碼 正文

易語言簡易通訊源碼

三葉資源網 2012-05-27 網絡相關源碼 324 ℃ 0 評論

資源介紹:

源碼利用易語言服務器和客戶組件實現簡易通信效果。

我愛自學易語言

.版本 2

.程序集 網絡封包
.程序集變量 m_Data, 字節集
.程序集變量 m_DataLen, 整數型
.程序集變量 m_errno, 整數型

.子程序 _初始化, , , 當基于本類的對象被創建後,此方法會被自動調用

m_errno = 0

.子程序 _銷毀, , , 當基于本類的對象被銷毀前,此方法會被自動調用



.子程序 clear, , 公開

m_Data = {  }
m_DataLen = 0
m_errno = 0

.子程序 init, , 公開

m_Data = {  }
m_DataLen = 0
m_errno = 0

.子程序 erase, , 公開
.參數 length, 整數型

m_DataLen = 取字節集長度 (m_Data) - length
m_Data = 取字節集右邊 (m_Data, m_DataLen)

.子程序 peek, 邏輯型, 公開

m_errno = packet_check ()
.如果真 (m_errno = 0)
    返回 (真)
.如果真結束
返回 (假)

.子程序 errno, 整數型, 公開

返回 (m_errno)

.子程序 packet_check, 整數型, 公開, 0 可讀取 1 等待寫入 -1 錯誤
.局部變量 length, 整數型
.局部變量 magic, 整數型

' ----------------
' int magic
' int length
' byte data[length]
' ----------------
.如果真 (m_DataLen < 8)
    返回 (1)
.如果真結束
magic = 取字節集數據 (m_Data, #整數型, 1)
.如果真 (magic ≠ 305419896)  ' magic = 0x0ODEDEAD
    返回 (-1)
.如果真結束
length = 取字節集數據 (m_Data, #整數型, 5)  ' check length >= data length
.如果真 (length < 0)
    返回 (-1)
.如果真結束
.如果真 (length > 10240)
    返回 (-1)
.如果真結束
.如果真 (m_DataLen - 8 < length)
    返回 (1)
.如果真結束
返回 (0)

.子程序 append, , 公開
.參數 data, 字節集

m_Data = m_Data + data
m_DataLen = 取字節集長度 (m_Data)

.子程序 read, 字節集, 公開
.局部變量 data, 字節集
.局部變量 length, 整數型

data = {  }
.如果真 (peek () = 假)
    返回 (data)
.如果真結束
length = 取字節集數據 (m_Data, #整數型, 5)
data = 取字節集中間 (m_Data, 9, length)
erase (length + 8)
返回 (data)

.子程序 write, , 公開
.參數 data, 字節集
.局部變量 length, 整數型
.局部變量 magic, 整數型
.局部變量 packet_data, 字節集

magic = 305419896
length = 取字節集長度 (data)

packet_data = 到字節集 (magic) + 到字節集 (length) + data
append (packet_data)

.子程序 getData, 字節集, 公開

返回 (m_Data)

.子程序 getLength, 整數型, 公開

返回 (m_DataLen)


文件下載


Tags:

來源:三葉資源網,歡迎分享,公衆号:iisanye,(三葉資源網④群:72857039

本文暫時沒有評論,來添加一個吧(●'◡'●)

歡迎 發表評論:

百度站内搜索
關注微信公衆号
三葉資源網④群:三葉資源網③群

網站分類
随機tag
LOLHOOK視頻上傳寬帶撥号網頁删除空cookieQQ消息後台發送模塊源碼鬥魚TCP協議單課基礎課程集合Shell外殼編程易語言對接貓池源碼動态支持庫AU商城httpwacth窗口特效今日頭條網易登錄kktv窗口位置控制模塊炫彩界面庫模塊
最新評論