為編程愛好者分享易語言教程源碼的資源網
易語言|按鍵精靈|app逆向|微信hook 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 每日必買商品
注冊機|遊戲腳本|透視輔助|視頻教程 收QQ協議|PC協議|安卓協議 收購QQ通訊協議|點擊聯系 收PCQQ協議|安卓QQ協議|聯系我 收易語言QQ協議|你有就找我 挂機,挂機器人服務器88一年

網站首頁 易語言相關 網絡相關源碼 正文

易語言檢測更新源碼

三葉資源網 2019-11-15 網絡相關源碼 134 ℃ 0 評論
.版本 2
.支持庫 internet
.支持庫 eAPI

.程序集 窗口程序集_啟動窗口

.子程序 __啟動窗口_創建完畢

檢測軟件更新 ()

.子程序 鳳凰_取文本中間, 文本型
.參數 文本, 文本型
.參數 左邊的文本, 文本型
.參數 右邊的文本, 文本型
.參數 起始位置, 整數型, 可空
.局部變量 開始, 整數型
.局部變量 結束, 整數型
.局部變量 長度, 整數型
.局部變量 内容, 文本型

開始 = 尋找文本 (文本, 左邊的文本, 起始位置, 真) + 取文本長度 (左邊的文本)
.如果真 (開始 = -1 + 取文本長度 (左邊的文本))
    返回 (“獲取失敗”)
.如果真結束
結束 = 尋找文本 (文本, 右邊的文本, 開始, 真)
.如果真 (結束 = -1)
    返回 (“獲取失敗”)
.如果真結束
長度 = 結束 - 開始
内容 = 取文本中間 (文本, 開始, 長度)
返回 (内容)

.子程序 檢測軟件更新
.局部變量 網頁源碼, 文本型

處理事件 ()
編輯框_當前版本.禁止 = 真
編輯框_最新版本.禁止 = 真
網頁源碼 = 到文本 (HTTP讀文件 (“http://tudouwangluo1.blog.163.com/”))  ' 這是一個 網易的 博客 日志,日志地址不會變,而且永久可以編輯 修改
編輯框_最新版本.内容 = 鳳凰_取文本中間 (網頁源碼, 字符 (176) + 字符 (到整數 (到文本 (460 ÷ 2))) + 字符 (177) + 字符 (到整數 (到文本 (950 ÷ 5))) + 字符 (到整數 (到文本 (41 × 5))) + 字符 (位異或 (176, 7)) + 到文本 ({ 163 }) + 字符 (251), 字符 (163) + 字符 (253) + 到文本 ({ 176 }) + 到文本 ({ 230 }) + 字符 (177) + 字符 (190) + 字符 (到整數 (到文本 (1854 ÷ 9))) + 到文本 ({ 178 }))
.判斷開始 (到小數 (編輯框_當前版本.内容) < 到小數 (編輯框_最新版本.内容))  ' 編輯框_當前版本  小于  編輯框_最新版本  就讓軟件更新
    信息框 (“發現新版本: ” + 編輯框_最新版本.内容, 16, “當前版本: ” + 編輯框_當前版本.内容, )
    打開指定網址 (“http://pan.baidu.com/s/1kTghycB”)  ' 百度網盤,推薦使用,你共享一個 文件夾 就可以了,文件夾的地址是不會變的
    ' 打開指定網址(“http://zm520.ys168.com”)            永碩網盤,你自己看着用,更新軟件也不錯
    程序自殺 ()
.默認

.判斷結束


.子程序 __啟動窗口_可否被關閉, 邏輯型

@中國戰線

文件下載

Tags:

來源:三葉資源網,歡迎分享,公衆号:iisanye,(三葉資源網④群:72857039

本文暫時沒有評論,來添加一個吧(●'◡'●)

歡迎 發表評論:

百度站内搜索
關注微信公衆号
三葉資源網④群:三葉資源網③群

網站分類
随機tag
Pc微信Hook源碼ASP網絡驗證RC4加密源碼限制窗口位置和尺寸TGP饑荒一鍵指令工具多線程注冊Accessible接口例子枚舉進程簡單多線程郵箱SSL發信檢測OD模塊枚舉IE插件硬盤遍曆異或校驗手勢驗證碼正則表達式工具BitBlt彙編版JS教程火山安卓
最新評論